Back

2- Check my Flash player

How do I install Flash?

The game requires a recent version of Flash (version 9 or higher).

Adobe Flash Player is a free program which is used to display animations and Internet games. To install Flash Player, download it in a few seconds from here :

Install the latest version of Flash Player

if problems persist, you could try uninstalling and reinstalling Flash Player. To uninstall, follow the instructions here.

Additional info for Linux users

The addition of an avatar doesn't work properly on some versions. Please update your player to resolve this problem :)

Using Flash Player in Firefox can cause certain in-game elements to not function correctly.

However, as the game was partially developed in Linux, we are doing all we can to ensure the gaming experience is as similar as possible .

One night, a long time ago, old Chuck saw the Horde and lived to tell the tale. The very sight made his buttcheeks clench like a vice. They have not been unclenched since! Unknown